could not load module "plain"

Besoin d'aide pour installer Asymptote ?
zariski
Messages : 126
Enregistré le : dim. 30 sept. 2012, 18:50

could not load module "plain"

Message non lupar zariski » sam. 12 janv. 2013, 15:04

Hello !
Voilà je suis bien embêté.
Avant ma pause de midi, je peux compiler mes docs asymptote.
Je vais casser la croute, je reviens, et Asymptote ne fonctionne plus !!!!
Voir fichier joint.
Je précise qu'avec Notepad++ c'est kifkif bourricot !!!!
Fichiers joints

[L’extension pdf a été désactivée et ne peut plus être affichée.]

Windows 7 - Winedit 7 - TeXLive2012 - Asymptote 2.16

Avatar de l’utilisateur
GM
Administrateur du site
Administrateur du site
Messages : 1318
Enregistré le : dim. 7 mars 2010, 14:50

Re: could not load module "plain"

Message non lupar GM » sam. 12 janv. 2013, 18:18

Bonjour,


bizarre, bizarre...
Le message date de 3h : le problème est-il résolu depuis ?
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://gmaths.net/asy/index/?filtre=arc triple
Fichiers utiles pour réaliser des graphes : gm_graphes.asy - gm_graphes_styles.asy
Mes configurations (le 01/02/15) :
PC n°1 :Windows 7 - Asymptote(2.32)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 14.04LTS - Asymptote(2.33SVN) + TexLive2014 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

zariski
Messages : 126
Enregistré le : dim. 30 sept. 2012, 18:50

Re: could not load module "plain"

Message non lupar zariski » sam. 12 janv. 2013, 18:20

ouf quelqu'un à mon secours !!!
Problème non résolu !
J'y perds mon latin.
Un instant j'ai soupçonné mon anti virus ...
Windows 7 - Winedit 7 - TeXLive2012 - Asymptote 2.16

Avatar de l’utilisateur
GM
Administrateur du site
Administrateur du site
Messages : 1318
Enregistré le : dim. 7 mars 2010, 14:50

Re: could not load module "plain"

Message non lupar GM » sam. 12 janv. 2013, 18:31

Je me demande si ce genre d'erreur n'est pas un problème de path... mais pourquoi aurait-il changé ?

En console (touches [Windows]+[R] ........ puis en tapant cmd + [Entrée]), la commande asy lance bien asymptote ?

Dans le fichier

Code : Tout sélectionner

.asy/config.asy

as-tu le chemin vers le dossier d'installation d'Asymptote ?

Code : Tout sélectionner

import settings;
dir="C:\Program Files (x86)\Asymptote";

(à adapter suivant ton installation).
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://gmaths.net/asy/index/?filtre=arc triple
Fichiers utiles pour réaliser des graphes : gm_graphes.asy - gm_graphes_styles.asy
Mes configurations (le 01/02/15) :
PC n°1 :Windows 7 - Asymptote(2.32)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 14.04LTS - Asymptote(2.33SVN) + TexLive2014 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

zariski
Messages : 126
Enregistré le : dim. 30 sept. 2012, 18:50

Re: could not load module "plain"

Message non lupar zariski » sam. 12 janv. 2013, 18:47

si je lance le petit programme suivant (cf fichier joint), j'ai bien un cercle rouge qui s'affiche en .eps.
Par contre, mettre : import settings;
dir="C:\Program Files (x86)\Asymptote";
en début de fichier ne règle pas mon soucis.
Quant au path (et je pense que le problème doit venir de là) je maitrise moins le truc...
Fichiers joints

[L’extension pdf a été désactivée et ne peut plus être affichée.]

Windows 7 - Winedit 7 - TeXLive2012 - Asymptote 2.16

Avatar de l’utilisateur
GM
Administrateur du site
Administrateur du site
Messages : 1318
Enregistré le : dim. 7 mars 2010, 14:50

Re: could not load module "plain"

Message non lupar GM » sam. 12 janv. 2013, 18:57

zariski a écrit :Par contre, mettre :

Code : Tout sélectionner

import settings;
dir="C:\Program Files (x86)\Asymptote";

en début de fichier ne règle pas mon souci.

Pas en début de fichier... mais dans le ficher que j'ai indiqué !
Tu demandes l'affichage des fichiers/dossiers cachés pour faire apparaître le dossier .asy qui est dans ton dossier d'utilisateur.
Image
Image
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://gmaths.net/asy/index/?filtre=arc triple
Fichiers utiles pour réaliser des graphes : gm_graphes.asy - gm_graphes_styles.asy
Mes configurations (le 01/02/15) :
PC n°1 :Windows 7 - Asymptote(2.32)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 14.04LTS - Asymptote(2.33SVN) + TexLive2014 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

zariski
Messages : 126
Enregistré le : dim. 30 sept. 2012, 18:50

Re: could not load module "plain"

Message non lupar zariski » sam. 12 janv. 2013, 19:07

oups quel c.. :oops:
En fait je n'ai rien dans : c:\Utilisateurs\Eric\.asy
mis à part le fichier "history" du petit programme lancé précédemment !
Fichiers joints

[L’extension pdf a été désactivée et ne peut plus être affichée.]

Modifié en dernier par zariski le sam. 12 janv. 2013, 19:11, modifié 1 fois.
Windows 7 - Winedit 7 - TeXLive2012 - Asymptote 2.16

Avatar de l’utilisateur
GM
Administrateur du site
Administrateur du site
Messages : 1318
Enregistré le : dim. 7 mars 2010, 14:50

Re: could not load module "plain"

Message non lupar GM » sam. 12 janv. 2013, 19:08

Conseil supplémentaire pour tout test de compilation (quand on rencontre des problèmes) : être dans un dossier qui ne comporte que le fichier que l'on veut compiler... pour être bien sûr qu'aucun autre fichier n'interfère.

Je pense à dire cela car j'ai le souvenir, il y a quelques années, de quelqu'un qui avait créé dans un dossier personnel un ficher asy qui avait le même nom que l'un des fichiers officiels d'Asymptote... et on avait galéré à trouver l'explication du problème.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://gmaths.net/asy/index/?filtre=arc triple
Fichiers utiles pour réaliser des graphes : gm_graphes.asy - gm_graphes_styles.asy
Mes configurations (le 01/02/15) :
PC n°1 :Windows 7 - Asymptote(2.32)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 14.04LTS - Asymptote(2.33SVN) + TexLive2014 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

Avatar de l’utilisateur
GM
Administrateur du site
Administrateur du site
Messages : 1318
Enregistré le : dim. 7 mars 2010, 14:50

Re: could not load module "plain"

Message non lupar GM » sam. 12 janv. 2013, 19:12

zariski a écrit :En fait je n'ai rien dans : c:\Utilisateurs\Eric\.asy

Asymptote peut fonctionner sans fichier config.asy dans une majorité de configurations, je pense,...

... mais quand on commence à avoir des problèmes, peut-être du fait d'une installation exotique (avec des lettres de partitions particulières), il vaut mieux préciser les choses dans un fichier config.asy qu'il faut alors ajouter.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://gmaths.net/asy/index/?filtre=arc triple
Fichiers utiles pour réaliser des graphes : gm_graphes.asy - gm_graphes_styles.asy
Mes configurations (le 01/02/15) :
PC n°1 :Windows 7 - Asymptote(2.32)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 14.04LTS - Asymptote(2.33SVN) + TexLive2014 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

zariski
Messages : 126
Enregistré le : dim. 30 sept. 2012, 18:50

Re: could not load module "plain"

Message non lupar zariski » sam. 12 janv. 2013, 19:19

pffiooooou je crois le problème résolu.
Je viens de créer un fichier "config.asy" que j'ai placé dans .asy
Je retourne tester tout ça ...
Windows 7 - Winedit 7 - TeXLive2012 - Asymptote 2.16


Retourner vers « Installation d'Asymptote »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité